Forexpf.Ru - Все о рынке Forex
   


8 (800) 700 00 67 
Forexpf.Ru - Торговля на Форекс Pro Finance Service - Online Forex Trading О компании Услуги Реклама Informer Контакты
Личный кабинет
Демо Реал
Открытие счета
Демо Реал
ProTrader 3.1
Котировки
Web Java
Графики
Web Java
Архив аналитики
Комментарии
Новости
Календарь
Форум




Rambler's Top100
Инструкция по пользованию программой Prochart
Программа ProChart - это онлайн система технического анализа, позволяющая получать информацию об изменениях курсов различных финансовых инстурментов на международном рынке в режиме реального времени, проводить исследование динамики рынка и оперативно прогнозировать будущее направление движения цен средствами базового технического и компьютерного анализа.
СОДЕРЖАНИЕ


1. Начало работы
2. Пиктограмма "Свойства окна"
3. Пиктограмма "Свойства графика"
4. Вспомогательная панель
5. Прокрутка
6. Параметр "кол-во данных"
7. Информационное поле
8. Содержание основного меню
   8.1 Меню Instruments
   8.2 Меню Chart Type
   8.3 Меню Time Scal
   8.4 Меню Tools
      8.4.1 Пункт меню Remove All
      8.4.2 Пункт меню Line
      8.4.3 Пункт меню Fibonacci Retracement - Уровни Фибоначчи[1]
      8.4.5 Пункт меню Fibonacci Fans - Веер Фибоначчи [1]
      8.4.6 Пункт меню Fibonacci Arc - Дуги Фибоначчи [1]
      8.4.7 Пункт меню Fibonacci Time Goal Analisis - Временные Цели Фибоначчи[5]
      8.4.8 Пункт меню Fibonacci Spiral - Фи-спираль[5]
      8.4.9 Пункт меню Fibonacci Time Zone - Временные зоны [1]
      8.4.10 Пункт меню Fibonacci phi-Channel - Фи-канал [5]
      8.4.11 Пункт меню Andrew's Pitchfork - Вилы Эндрюса [1]
      8.4.12 Пункт меню Horizontal Line - Горизонтальная линия
      8.4.13 Пункт меню Vertical Line - Вертикальная линия
      8.4.14 Пункт меню Add Text - Подписи
   8.5 Меню Indicators
   8.6 View
      8.6.1 Periods
      8.6.2 Quotes history
      8.6.3 Bars to right
      8.6.4 Show/set to prev. close zero price
      8.6.5 Hide Informer
      8.6.6 Hide Volume
      8.6.7 Export to Metastock
      8.6.8 Print
      8.6.9 New Window
      8.6.10 Informers
      8.6.11 Save
      8.6.12 Load
      8.6.13 Help
      8.6.14 About Prochart

1. Начало работы.
Для запуска программы необходимо войти на главную страницу сайта с адресом www.forexpf.ru в раздел "Графики" и кликнуть по подразделу "Java". Появится новое окно состоящее из мозаики клавиш с названиями предлагаемых для отображения инструментов - см. на рис. 1.

В этом окне необходимо кликнуть по клавише с нужным для построения графика названием пары валют, например по клавише с названием "EUR/USD". После небольшой паузы (загрузка данных) появится окно с графиком со следующими параметрами: период формирования свечи 1 мин., количество свечей 335, вид графика - Bar Chart (штриховой график). Пример окна представлен на рис. 2.

рис. 1.

рис. 2.
Экран программы ProChart содержит следующие основные компоненты:
  • пиктограма "Свойства окна";
  • пиктограмма "Свойства графика";
  • строка меню, объединяющая основные функции и команды ProChart;
  • вспомогательная панель, объединяющая пиктограммы некоторых основных команд;

  • полоса прокрутки графика;
  • параметр кол-во баров (определяет число баров используемых при формировании графика);
  • рабочая область;
  • информационное поле;

    Далее рассмотрим перечисленные компоненты экрана.

    перейти к содержанию




2. Пиктограмма "Свойства окна".
Под изображением пиктограммы "Свойства окна" объединены семь параметров, определяющих визуальное изображение рабочей области экрана.

Для изменения параметров рабочей области необходимо щелкнуть левой кнопкой мыши по пиктограмме "Свойства окна". Появится окно с одним пунктом Properties. Кликая по этому пункту левой кнопкой мыши, вызываем появление окна Window properties (см. на рис. 3) c параметрами:

рис. 3
  • Sync with - параметр связанности окон (при прокрутке окна, с которым синхронизировано текущее, оно также изменит свое положение);
  • Backgr. bottom - нажимаем в окне, соответствующую этому параметру клавишу (серого цвета), попадаем в окно для задания цвета нижней части фонового поля графика;
  • Backgr. top - нажимаем в окне, соответствующую этому параметру клавишу (серого цвета), попадаем в окно для задания цвета верхней части фонового поля графика;
  • Log Sсale base - значение параметра соответствует основанию логарифмической шкалы ценовой оси;
  • Grid visible - параметр, определяющий отображение сетки (при наличии галочки сетка отображается, при отсутствии - не отображается) ;
  • Grid color - нажимаем в окне, соответствующую этому параметру клавишу (серого цвета), попадаем в окно для задания цвета сетки;
  • Grid Style - параметр, определяющий стиль изображения сетки .
При задании разных цветов в параметрах Backgr.bottom и Backgr.top получим фон графика, изменяющего цвет плавно снизу вверх. Для задания однотонного фона необходимо задать одинаковые параметры Backgr.bottom и Backgr.top.

перейти к содержанию




3. Пиктограмма "Свойства графика".
Под изображением пиктограммы "Свойства графика" объединены семь основных параметров, определяющих изображение ценового графика на экране.

Для изменения параметров графика необходимо щелкнуть левой кнопкой мыши по пиктограмме "Свойства графика". Появится окно с пунктами Properties и Delete. Кликая по пункту Properties левой кнопкой мыши, вызываем появление окна c параметрами:
  • Visible - параметр, определяющий отображение графика (при наличии галочки график отображается, при отсутствии - не отображается);
  • Line width - задание параметра, определяющего толщину линии ценового графика в случае использования графика линейного типа;
  • Color - нажимаем в окне, соответствующую этому параметру клавишу (серого цвета) и попадаем в окно для задания цвета графика;
  • Bid Color - нажимаем в окне, соответствующую этому параметру клавишу (серого цвета) и попадаем в окно для задания цвета графика , отображающего цены Bid (используется только для графиков тикового типа);
  • Ask Color - нажимаем в окне, соответствующую этому параметру клавишу (серого цвета) и попадаем в окно для задания цвета графика, отображающего цены Ask (используется только для графиков тикового типа);
  • Volume Color - нажимаем в окне, соответствующую этому параметру клавишу (серого цвета) и попадаем в окно для задания цвета графика, отображающего гистограмму Volume (в случае отображения этой гистограммы на экране).

    перейти к содержанию




4. Вспомогательная панель.
Вспомогательная панель находится в правом нижнем углу активного окна и содержит четыре пиктограммы , кликая по которым можем производить следующие действия:
  • "><" - вывести на экран всю загруженную историю;
  • "-" - сжать изображение на экране;
  • "+" - расширить изображение на экране;
  • "A" или "M" - кликая по этой пиктограмме пользователь переводит отображения графика из режима A в режим M и обратно.
    При использовании последней пиктограммы в режиме A график отображается по ценовой оси на весь экран. В режиме M пользователь может изменять интервал отображения графика как по ценовой оси так и по временной оси. Для этого он может установить крестик на поле ценовой оси (чуть правее оси Y) и, зафиксировав его мышкой, поводить вверх/вниз, вызывая изменения в выводимом по оси Y интервале. Такие же манипуляции пользователь может делать и с временной осью - установить крестик на поле оси времени (чуть ниже оси X) и, зафиксировав его мышкой, поводить влево/вправо, вызывая изменения в выводимом по оси X интервале. В режиме M пользователь может сдвигать кривую графика вверх/вниз - зафиксировать мышкой на самом графике и двигать ей вверх/вниз по экрану, добиваясь более удобного вывода данных на экране.

    перейти к содержанию




5. Прокрутка.
В левой нижней части экрана находится окно Прокрутка (см. на рис. 2), предназначенное для перемещения графика по рабочей области вдоль оси времени. Позиция бегунка в полосе прокрутка указывает часть графика, выведенного в данный момент в рабочую область. Перемещение графика по рабочей области можно делать следующим образом: зафиксировать мышкой на самом графике и двигать ей влево/вправо по экрану, добиваясь более удобного вывода данных на экране.
перейти к содержанию

6. Параметр "кол-во данных".
Массив исторических данных, загружаемых в программу определяется значением параметра "кол-во данных" (см. на рис. 2), расположенного в правом верхнем углу графика. Для изменения загружаемых данных необходимо изменить значение параметра "кол-во данных". Задавая целое значение в этом окне, пользователь определяет число загружаемых временных периодов (например, свечей).

перейти к содержанию




7. Информационное поле.
В информационном поле (см. на рис. 2) представляются:
  • временные и ценовые координаты положения указателя мыши на рабочей области;
  • значения параметров баров или свечей, соответствующих временной координате указателя мыши.

    перейти к содержанию




8. Содержание основного меню
Каждый из пунктов меню объединяет набор команд , имеющих общую функциональную направленность: Instruments, Chart Type, Time Scale, Tools, Indicators, View. На рис.4 представлено изображение Основного меню:


рис.4

Далее рассмотрим каждое из этих меню.

перейти к содержанию




8.1 Меню Instruments
Меню Instruments содержит список инструментов, которые можно использовать для формирования графиков. Список доступных названий символов Вы можете уточнить у Вашего поставщика системы ProChart.

перейти к содержанию




8.2 Меню Chart Type
В меню Chart Type Вы можете задавать тип формируемого графика:
  • Line - линейный график по ценам закрытия заданного в пункте Time Scale временного интервала;
  • Dot - график из набора точек, соответствующих ценам закрытия заданного в пункте Time Scale временного интервала;
  • Dot Line - совместное изображение линейного графика и графика из точек, соответствующих ценам закрытия заданного в пункте
  • Time Scale - временного интервала;
  • Solid - соответствует линейному графику с двумя разными цветовыми фонами, соответствующими подпространствам ниже и выше линейного графика;
  • Forest - аналог линейного графика, построенного по ценам закрытия и представляемого в виде гистограммы с центральной осью, соответствующей текущей котировке (последняя цена на графике);
  • Bar - бары;
  • Candle - японские свечи;

перейти к содержанию




8.3 Меню Time Scale
Временной период для формирования графика выбирается из меню Time Scale:
  • Tick - тиковый график;
  • 1 Minute - 1 минута;
  • 5 Minute - 5 минут;
  • 15 Minute - 15 минут;
  • Hourly - 1 час;
  • Daily - 1 день;
  • Monthly - 1 месяц;

перейти к содержанию




8.4 Меню Tools
Пример окна программы ProChart, содержащее меню Tools представлено на рис.5.

рис.5

Меню Tools содержит набор графических инструментов, которые программа ProChart позволяет использовать на графиках. Каждый из пунктов меню содержит или командное действие над графическими инструментами (соответствует первому пункту меню) или название графического инструмента. Для того, чтобы добавить новый графический инструмент на графике нажмите левой кнопкой мыши кнопку, соответствующую выбранному инструменту на панели Tools. Данная кнопка станет утопленной, и Вы сможете воспользоваться данным инструментом. Перечень графических инструментов: Remove All, Line, Fibonacci Retracement, Fibonacci Fans, Fibonacci Arc, Fibonacci Time Goal Analisis, Fibonacci Spiral, Fibonacci Time Zone, Fibonacci phi-channel, Andrew's Pitchfork, Horizontal Line, Vertical Line, Add Text.

Далее рассмотрим подробнее каждый из пунктов меню.

перейти к содержанию




8.4.1 Пункт меню Remove All
Пункт Remove All - содержит командное действие "удалить все графические инструменты, изображенные на графике". Нажатием по этому пункту удаляются все графические инструменты из рабочей области.

перейти к содержанию




8.4.2 Пункт меню Line
Нажатием по пункту Line активизируете процесс рисования линий. Линии (точнее - отрезки) строятся заданием положения двух точек, определяющих границу отрезка, через который эта линия проводится. При этом при определении положения двух точек пользователь может воспользоваться режимом "прилипания", т.е. привязывать положение точек к определенному положению одного из ценовых параметров, соответствующей по времени свечи. Параметры режима "прилипания" отображаются в меню пункта, всплывающее при выборе курсором пункта Line и содержащее следующие параметры:
  • Freehand - режим "прилипания" не используется;
  • Stick to close - заданное положение точек перемещается на цены закрытия свечей;
  • Stick to open - заданное положение точек перемещается на цены открытия свечей;
  • Stick to high - заданное положение точек перемещается в точку на графике соответствующую положению максимума свечи;
  • Stick to low - заданное положение точек перемещается в точку на графике соответствующую положению минимума свечи;
После того, как Вы перешли в режим рисования линии (см. выше) нажмите и отпустите левую кнопку мыши в той точке диаграммы, где Вы хотите видеть первую точку. Затем нажмите и отпустите левую кнопку мыши там, где должна быть вторая точка. После этого задание линии будет завершено и между этими двумя точками будет нарисован отрезок. Чтобы изменить его свойства (цвет, толщину или стиль линии и т.д.) нажмите левой кнопкой мыши на любой точке отрезка, при этом его базовые точки будут отмечены квадратами и появится меню, содержащее три вкладки: Properties, Clone, Delete.
При выборе (двукратное нажатие левой кнопкой мыши) вкладки Properties появляется дополнительное окно Tool properties с одной нажатой вкладкой Appearance, содержащее следующие параметры:
  • Stick to - включать режим "прилипания" заданных при построении двух точек относительно параметров соответствующих им по времени свечей;
  • Color - цвет изображаемого отрезка;
  • Style - выбор графического стиля изображения отрезка;
  • Width - параметр, определяющий толщину изображения отрезка;
  • Is Ray - при отсутствии галочки продолжение отрезка не изображается, при наличии галочки отрезок изображается в виде луча с началом из точки 1 и продолжением из точки 2;
  • Ray Style - выбор графического стиля изображения продолжения отрезка в случае изображения луча.
При выборе (двукратное нажатие левой кнопкой мыши) вкладки Clone на экране появляется подобный по длине отрезок, параллельный заданному.
При выборе (двукратное нажатие левой кнопкой мыши) вкладки Delete выделенный отрезок удаляется с экрана.
Далее во всех инструментах, если это не будет оговорено отдельно, нажатие вкладок Clone и Delete будет означать в первом случае создание дубля изображения инструмента, во втором - удаление инструмента.

перейти к содержанию




8.4.3 Пункт меню Fibonacci Retracement - Уровни Фибоначчи[1]
Для построения этого инструмента используется алгоритм задания значений двух базовых уровней на основе которых строятся Уровни Фибоначчи. Значения базовых уровней определяются заданием положения на графике двух точек.
Алгоритм задания и построения Уровней Фибоначчи на основе задания положения двух точек следующий. Нажатием по пункту Fibonacci Retracement активизируете процесс рисования уровней. После того, как Вы перешли в режим рисования Уровней Фибоначчи нажмите и отпустите левую кнопку мыши в той точке диаграммы, где Вы хотите видеть первую точку. Затем нажмите и отпустите левую кнопку мыши там, где должна быть вторая точка. После завершения рисования уровни Фибоначчи появятся на диаграмме. Полученные уровни можно разделить на две группы. Первая группа - уровни, находящиеся в ценовом диапазоне между значениями цен двух заданных точек. Это так называемые Уровни Коррекции Фибоначчи. Эти уровни располагаются по порядку возрастания расчетных коэффициентов в направлении от второй точки к первой, т.к. строятся для рассмотрения коррекции от движения цены от первой точки ко второй. Вторая группа - уровни, построенные в продолжение изменения цены от точки один к точки два. Это так называемые Уровни Расширения Фибоначчи. Пример построения уровней приведен на :

рис.6 Интерпретация Уровней Фибоначчи основывается на стандартных правилах интерпретации линий поддержки и сопротивления.

Чтобы изменить свойства линии (цвет, толщину или стиль линии и расположение линий) нажмите левой кнопкой мыши на любой точке отрезка, соединяющего точки 1 и 2. При этом базовые точки будут отмечены квадратами цвета линий и появится меню, в котором необходимо выбрать пункт Properties для изменения свойств уровней Фибоначчи. При нажатии вкладки Properties появится окно Tool properties (см. на рис. 7) с нажатой вкладкой Parameters и второй вкладкой - Appearance.

При нажатой вкладке Parameters имеем окно с десятью параметрами L0%-L9%. Значения этих параметров определяют положение на графике расчетных уровней Фибоначчи. Эти значения пользователь может изменять по своему усмотрению. Если какой либо параметр имеет значение меньше 100, то он относится к первой группе Уровней Фибоначчи. Если значение больше чем 100, то ко второй.
рис.7

При нажатой вкладке Appearance в окне Tool properties появляются параметры Stick to, Color, Style, Width, Is Ray, Ray Style. Эти параметры аналогичны соответствующим параметрам в п. 8.4.2.

перейти к содержанию




8.4.5 Пункт меню Fibonacci Fans - Веер Фибоначчи [1].
Fibonacci Fans подробно изложены в [1]. Для построения этого инструмента, так же как и в предыдущем пункте, используется алгоритм задания двух базовых уровней положением двух точек на рабочем поле графика. Имеется возможность выбора режима "прилипания" - аналогично п. 8.4.2. Чтобы изменить свойства инструмента (цвет, толщину или стиль линии и т.д.) нажмите левой кнопкой мыши на любой точке отрезка, при этом его базовые точки будут отмечены квадратами и появится меню, содержащее три пункта: Properties, Clone, Delete.
При выборе пункта Properties появится окно Tool properties с нажатой вкладкой Parameters и второй вкладкой - Appearance. При нажатой вкладке Parameters имеем окно с тремя параметрами L0%, L1%, L2%. Значения этих параметров определяет уровни Фибоначчи, через которые проводятся линии тренда. Эти значения пользователь может изменять по своему усмотрению.
При нажатой вкладке Appearance появляется окно с параметрами Stick to, Color, Style, Width, Is Ray, Ray Style. Эти параметры аналогичны соответствующим параметрам в п. 8.4.2.

перейти к содержанию




8.4.6 Пункт меню Fibonacci Arc - Дуги Фибоначчи [1].
Fibonacci Fans подробно рассмотрены в [1]. Алгоритм задания инструмента и изменения его параметров соответствует п. 8.4.3. Отличия имеем в окне Tool properties при нажатой вкладки Appearance - в окне задаются параметры Stick to, Color, Style, Width, а так же новый параметр Show Full Arc. При наличии галочки в параметре Show Full Arc на рисунке отображаются полные окружности. При отсутствии галочки - изображаются полу-окружности.

перейти к содержанию




8.4.7 Пункт меню Fibonacci Time Goal Analisis - Временные Цели Фибоначчи[5].
Fibonacci Time Goal Analisis подробно рассмотрены в [5].
ÀДля построения этого инструмента используется алгоритм задания положения опорного отрезка, на основании которого строятся Временные Цели Фибоначчи. Отрезок задается расположением в рабочей области двух точек - см. на рис. 8. Для расчета за основание берется временное расстояние между двумя точками и, используя расчетные коэффициенты, определяются Временные Цели Фибоначчи. Расчетные коэффициенты пользователь может изменять. Для этого необходимо нажать левую кнопку мыши на любой точке опорного отрезка и выбрать вкладку Properties в появившемся меню. Появится окно Tool properties с нажатой вкладкой Parameters, содержащее значения расчетных коэффициентов - параметры L0%-L5%. При нажатой вкладки Appearance имеем полное соответствие параметров с п. 8.4.3.

рис.8

перейти к содержанию




8.4.8 Пункт меню Fibonacci Spiral - Фи-спираль[5].
Fibonacci Spiral подробно рассмотрена в [5]. Для задания используется алгоритм задания опорного отрезка расположением двух точек на рабочем поле графика - см. на рис.9. Точки отрезка задаются так же как и в п. 8.4.3.

рис.9

Чтобы изменить свойства инструмента (цвет, толщину или стиль линии и т.д.) нажмите левой кнопкой мыши на любой точке отрезка, при этом его базовые точки будут отмечены квадратами, и появится меню, содержащее три пункта: Properties, Clone, Delete.
При выборе пункта Properties появится окно Tool properties с нажатой вкладкой Parameters и второй вкладкой - Appearance. В окне Tool properties при нажатой вкладке Parameters определяются два параметра: K - темп роста спирали; Reverse - тип спирали (при наличии галочки в этом параметре на рисунке изображается правосторонняя спираль, при отсутствии - левосторонняя). При нажатой вкладки Appearance появляются три параметра: Color, Style, Width.

перейти к содержанию




8.4.9 Пункт меню Fibonacci Time Zone - Временные зоны [1].
Fibonacci Time Zone подробно рассмотрены в [1]. Временные зоны Фибоначчи - ряд вертикальных линий с интервалами Фибоначчи 1,2,3,5,8,13, 21,34 и т.д. Для отображения на экране Временных зон необходимо выбрать пункт меню Fibonacci Time Zone, и далее переместить указатель мыши в то место рабочей области, с которого будут формироваться расчетные зоны. Изменение параметров при нажатой вкладки Properties соответствует изложенному в п. 8.4.3.

перейти к содержанию




8.4.10 Пункт меню Fibonacci phi-Channel - Фи-канал [5].
Fibonacci phi-Channel подробно рассмотрен в [5]. Для задания Фи-каналов используется алгоритм определения канала по трем точкам - пользователь задает на графике три точки. После того, как Вы перешли в режим рисования каналов нажмите и отпустите левую кнопку мыши в той точке диаграммы, где Вы хотите видеть первую точку канала. Затем нажмите и отпустите левую кнопку мыши там, где должна быть вторая точка канала. Затем нажмите и отпустите левую кнопку мыши там, где должна быть третья точка канала. После этого формирование фи-канала будет завершено и он появится на диаграмме. До указания третьей точки Вы можете прервать построение канала, для этого нажмите правую кнопку мыши. На основании трех заданных точек программа строит изображение семи лучей. Первый луч строится с началом из точки один и проходит через точку два. Второй луч стоится параллельным первому лучу и проходит через точку три. Расстояние между этими двумя лучами берется в качестве ширины Фи-канала. Это расстояние устанавливается как 1,000. Далее строятся остальные пять лучей параллельных первым двум лучам, - наносятся параллельные линии на расстоянии от луча 2 значений ряда ФИ, начиная с 0,618-кратного размера канала и далее 1,000-кратного, 1,618-кратного, 2,618-кратного, 4,236-кратного и так далее. Первый луч и остальные пять лучей располагаются с противоположных сторон относительно луча два.


рис.10

Интерпретация линий Фи-канала основывается на стандартных правилах интерпретации линий поддержки и сопротивления.
Чтобы изменить свойства изображения канала (цвет, толщину или стиль линии и т.д.) нажмите левой кнопкой мыши на любой точке отрезка между точкой один и точкой два или отрезка между точками один и точками три. При этом его базовые точки будут отмечены квадратами цвета канала и появится меню, в котором необходимо выбрать пункт Properties для изменения свойств канала. Появится окно с вкладками Parameters и Appearance. При нажатой первой вкладке появятся значения коэффициентов, используемых при расчетах сформированных опорных линий. Значения этих коэффициентов пользователь может изменять. При нажатой вкладки Appearance появляется окно с параметрами Stick to, Color, Style, Width, Is Ray, Ray Style. Эти параметры аналогичны соответствующим параметрам в п. 8.4.2.

перейти к содержанию




8.4.11 Пункт меню Andrew's Pitchfork - Вилы Эндрюса [1].
Andrew's Pitchfork подробно рассмотрены в [1]. Для задания Вил Эндрюса используется алгоритм задания трех точек - пользователь задает на графике три точки, так же как и в п. 8.4.10. На основании трех заданных точек программа строит изображение трех лучей. Первый луч строится с началом из точки один и проходит через середину отрезка, соединяющего точки два и три. Это линия называется "рукояткой" вил. Далее с началом из точек два и три проводится два луча, параллельных первому лучу. Эти линии называются "зубьями" вил. Интерпретация Вил Эндрюса основывается на стандартных правилах интерпретации линий поддержки и сопротивления.


рис.11

перейти к содержанию




8.4.12 Пункт меню Horizontal Line - Горизонтальная линия.
При выборе этого пункта меню на экране появляется изображение горизонтальной линии, перемещающейся вслед за положением на экране указателя мыши. Значение цены, соответствующей положению линии в рабочей области подписывается на экране над линией. После однократного клика левой кнопкой мыши изображение горизонтальной линии фиксируется на экране. Наведением указателя мыши на горизонтальную линию можно перемещать положение линии по экрану.

перейти к содержанию




8.4.13 Пункт меню Vertical Line - Вертикальная линия.
При выборе этого пункта меню на экране появляется изображение вертикальной линии, перемещающейся вслед за положением указателя мыши. Значение времени открытия свечи, соответствующей положению линии на экране подписывается. После однократного клика левой кнопкой мыши изображение горизонтальной линии фиксируется на экране. Наведением указателя мыши на вертикальную линию, можно перемещать положение линии по экрану.

перейти к содержанию




8.4.14 Пункт меню Add Text - Подписи.
При выборе этого пункта меню на экране появляется изображение слова "Text", которое привязывается к положению указателя мыши. После однократного клика левой кнопкой мыши положение изображения "Text" фиксируется. После нажатия левой кнопкой мыши на изображение "Text" появится меню, из которого необходимо выбрать пункт Properties. Появится окно, содержщее следующие параметры:
  • Text - содержание задаваемого текста (используются как буквенные так и цифровые изображения), которое может изменять пользователь;
  • Color - цвет изображения;
  • Size - размер изображения;
  • Stiсk to - включить режим "прилипания" изображения относительно параметров, соответствующих ему по времени свечей;
Наведением указателя мыши на изображение и фиксацией левой кнопкой мыши, можно перемещать его положение по экрану.

перейти к содержанию




8.5 Меню Indicators.
Меню Indicators содержит набор пунктов, при использовании которых пользователь может добавлять в рабочее окно графики вспомогательных индикативных функций (индикаторы и осцилляторы), а так же производить над этими графиками некоторые вспомогательные действия. Меню Indicators представлено на рис.12.
Для того чтобы выбрать необходимую функцию или действие нажмите левой кнопкой мыши кнопку соответствующей панели на Indicators. Данная кнопка станет утопленной, и Вы сможете воспользоваться выбором в появившемся окне. Само окно разбито горизонтальными линями на четыре списка пунктов:
  • список 1 содержит 3 пункта, соответствующих типовым вспомогательным действиям с графиками;
  • список 2 - 10 пунктов, соответствующих вспомогательным функциям;
  • список 3 - 13 пунктов, соответствующих вспомогательным функциям;
  • список 4 - 1 пункт, соответствующий вспомогательной функции;
Все используемые в программе ProChart вспомогательные индикативные функции из списков 2 и 3 подробно описаны и рассмотрены в соответствующей литературе, например в [1], [2], [3], [4]. Поэтому подробное их описание с изложением основных принципов применения выходит за рамки данной инструкции. Далее в инструкции мы рассмотрим возможности задания используемых параметров функций.


Для того чтобы выбрать необходимую функцию или действие нажмите левой кнопкой мыши кнопку соответствующей панели на Indicators. Данная кнопка станет утопленной, и Вы сможете воспользоваться выбором в появившемся окне. Само окно разбито горизонтальными линями на четыре списка пунктов:
  • список 1 содержит 3 пункта, соответствующих типовым вспомогательным действиям с графиками;
  • список 2 - 10 пунктов, соответствующих вспомогательным функциям;
  • список 3 - 13 пунктов, соответствующих вспомогательным функциям;
  • список 4 - 1 пункт, соответствующий вспомогательной функции;
Все используемые в программе ProChart вспомогательные индикативные функции из списков 2 и 3 подробно описаны и рассмотрены в соответствующей литературе, например в [1], [2], [3], [4]. Поэтому подробное их описание с изложением основных принципов применения выходит за рамки данной инструкции. Далее в инструкции мы рассмотрим возможности задания используемых параметров функций.


рис.12
перейти к содержанию

8.5.1
Список 1 содержит пункты, при использовании которых пользователь может производить основные вспомогательные действия над окнами функций из списка 2 и 3. В эту группу входят следующие пункты - Remove all, Hide all, Show all.
В случае, если пользователь кликнет по первому пункту (Remove all), то в рабочем окне удалятся все построенные ранее вспомогательные индикативные функции.
Кликая по пункту Hide all, пользователь свертывает окна содержащие кривые функций из списка 3 в меню Indicators. Кликая по пункту Show all, пользователь восстанавливает окна содержащие кривые функций из списка 3 в меню Indicators, которые были свернуты при использовании пункта Hide all.

перейти к содержанию




8.5.2
Список 2 содержит пункты, при использовании которых пользователь может добавлять в рабочее пространство ценового графика кривые графиков вспомогательных индикативных функций. Этот список содержит функции, шкала значений которых совпадает с ценовой шкалой, в следствии чего они представляются в одном рабочем пространстве с графиком цены.
Список 2 содержит следующий набор функций:
  • Alligator;
  • Bollinger;
  • Envelope;
  • Ichimoku;
  • Ketler Channel;
  • Linear Regression Indicator;
  • Moving average;
  • Adaptive Moving Average;
  • Price Channel;
  • Parabolic SAR;
Для того что бы добавить график вспомогательной индикативной функции необходимо выбрать её название из списка 2 в меню Indicators и кликнуть левой кнопкой мыши по соответствующей названию панели. Появится окно настройки вспомогательной функции, содержащее две вкладки Parameters и Appearance. При нажатой вкладке Parameters отображаются следующие параметры, которые используются в расчетах необходимой для построения функции:
  • Period - используемый расчетный период при расчете рассматриваемой функции;
  • Source - источник данных (open, close, high, low и т.п., по умолчанию - close);
  • Type - название алгоритма, используемого в расчетах данной функции;
  • Yfactor - коэффициент растяжения по оси ординат (по умолчанию - 1.0).
При нажатой вкладке Appearance отображается перечень параметров, которые определяются для графического отображения расчетной функции на экране:
  • Visible - определяет режим отображения или не отображения графика вспомогательной функции на экране (наличие галочки - отображать кривую на экране; отсутствие галочки - не отображать);
  • Shift - сдвиг графика вспомогательной функции по оси абсцисс (по умолчанию - 0);
  • Width - толщина изображения кривой функции (по умолчанию - 1);
  • Style - стиль изображения кривой функции на экране (по умолчанию - line);
  • GradiendType - тип градиента изменения цвета (если существует) между двумя элементами индикатора (по умолчанию - simple);
  • Color - цвет элемента индикатора.
После появления окна настройки вспомогательной функции пользователь может (если это необходимо) изменить параметры расчетной функции, используя вкладки Parameters и Appearance, и после нажатия клавиши "apple" необходимая функция появится на экране. Нажатие клавиши "cancel" означает отказ от изображения вспомогательной функции.
рис.13
После того как функция представлена на графике, на экране появляется изображение её пиктограммы (на рис.13 обозначена пиктограммой "Свойства функции"), с цветом соответствующим цвету кривой функции, а так же содержащей название функции и основные её параметры. Эта пиктограмма появляется в той же строке, что и пиктограмма "Свойства графика" (см. на рис. 2). Для того, что бы изменить параметры функции необходимо кликнуть один раз левой кнопкой мыши по соответствующей ей пиктограмме. Появится меню с двумя пунктами: Properties и Delete. Кликая по пункту Delete, пользователь удаляет изображение кривой функции с экрана. Если кликнуть по пункту Properties, то появится то же окно настройки вспомогательной функции, содержащее две вкладки Parameters и Appearance, что и добавлении графика функции на экран.

перейти к содержанию




8.5.3
Список 3 содержит пункты, при использовании которых пользователь может добавлять в отдельные рабочие пространства кривые графиков вспомогательных индикативных функций. Этот список содержит функции размерность значений которых отличаются от размерности ценового графика (точнее, существенно отличаются от значений ценового графика), в следствии чего они представляются в отдельных рабочих пространствах.
Список 3 содержит следующий набор функций:
  • Average Diractional Movement Index;
  • Aroon;
  • Average true range;
  • CCI;
  • Chanal momentum oscillator;
  • MACD;
  • Momentum;
  • Price oscillator;
  • Qstick;
  • ROC;
  • RSI;
  • Stochastic oscillator;
  • Stochastic slow oscillator;
  • Positive volume index;
Для того что бы добавить график вспомогательной индикативной функции необходимо выбрать её название из списка 3 в меню Indicators и кликнуть левой кнопкой мыши по соответствующей названию панели. Появится окно настройки вспомогательной функции, содержащее две вкладки Parameters и Appearance. При нажатой вкладке Parameters отображаются следующие параметры, которые используются в расчетах необходимых для построения функции:
  • Period - используемый период при расчете рассматриваемой функции;
  • Source - источник данных (open, close, high, low и т.п., по умолчанию - close);
  • Type - название алгоритма, используемого в расчетах данной функции;
При нажатой вкладке Appearance отображается перечень параметров, которые определяются для графического отображения расчетной функции на экране:
  • Win num - номер окна (номерация производится для окон вспомогательных функций), существует возможность добавить сколько угодно (теоретически) для того, чтобы расположить 2-а и более индикаторов в одном окне нужно зайти в св-ва исходного индикатора и изменить данный парам;
  • Style - стиль изображения кривой функции на экране (по умолчанию - line)
  • Width - толщина изображения кривой функции (по умолчанию - 1)
  • Color - цвет элемента индикатора.
После появления окна настройки вспомогательной функции пользователь может (если это необходимо) изменить параметры расчетной функции, используя вкладки Parameters и Appearance, и после нажатия клавиши "apply" необходимая функция появится на экране. Нажатие клавиши "cancel" означает отказ от изображения вспомогательной функции.

рис.14

После того как функция представлена на экране в отдельном окне, в левом верхнем углу этого отдельного окна появляется изображение двух пиктограмм: "Свойства окна функции" и "Свойства функции". Последняя пиктограмма имеет цвет, соответствующий цвету кривой функции и содержит название функции и основные её параметры. Для того, что бы изменить параметры функции необходимо кликнуть один раз левой кнопкой мыши по соответствующей пиктограмме. Появится меню с двумя пунктами: Properties и Delete. Кликая по пункту Delete, пользователь удаляет изображение кривой функции с экрана. Если кликнуть по пункту Properties, то появится то же окно настройки вспомогательной функции, содержащее две вкладки Parameters и Appearance, что и при добавлении графика функции на экран.
Используя параметр Win num, можно совмещать кривые графиков для разных функций в одном окне. При создании новых окон для вспомогательных функций программа автоматически номерует эти окна, присваивая соответствующее значение параметру Win num. Тогда изменяя значение этого параметра, пользователь может совмещать несколько кривых в одном окне. Например, пользователь создал два вспомогательных окна функций CCI (Win num=1) и RSI (Win num=2). Тогда можно совместить эти два графика, двумя способами. Первый - в параметрах функции CCI задать Win num=2, а для RSI оставить Win num=2. Второй - в параметрах функции RSI задать Win num=1, а для CCI оставить Win num=1. В результате, обе кривые совместятся в одном окне.

перейти к содержанию




8.5.4
Список 4 содержит один пункт, при использовании которого пользователь может самостоятельно сформировать вспомогательную индикативную функция, и добавлять график этой функции в отдельное рабочее пространство.
Добавляемый пользователем индикатор описывается выражением, которое задается строкой и может состоять из математических функций (sin, cos), а также заранее определенных функций, таких как close, open.
Например:
  • close(x) - возвратит значение закрытия в т. Х
  • close(x-20) - то же, но со смещением во времени
  • hh(x,10) - макс. цена за период (10) в т. Х
  • LL(x,20) - мин. цена за период (20) в т. Х
  • MA(close(x),x,20) - МА(скользящая средняя, ), построенная по ценам закрытия, в т. Х, период - 20
  • MA(close(x),x+5,20) - то же. но со смещением 5
  • MMA(open(x),x,10) - modified ma для цен открытия
и т.д., включая комбинации ...

перейти к содержанию




8.6 View
Меню View содержит набор вспомогательных режимов, которые программа ProChart позволяет использовать при работе с графиками. Для того чтобы выбрать необходимый режим работы или изменить параметр нажмите левой кнопкой мыши кнопку соответствующую выбранному инструменту на панели View. Данная кнопка станет утопленной, и Вы сможете воспользоваться данным инструментом. Далее рассмотрим подробнее каждый из пунктов меню.

перейти к содержанию




8.6.1 Periods
Выбирая этот пункт меню попадаем в окно Enter Period, в котором пользователь может менять значение одного параметра - количество загружаемых в память программы периодов. Например, в случае свечного бара - количество загруженных свечей. При начальном формировании окна задается значение 335 баров.

перейти к содержанию




8.6.2 Quotes history.
При выборе этого пункта меню появляется окно, в котором представлена загруженная в память программы и отображаемая на графике история изменения значений выбранного инструмента в табличном виде.

перейти к содержанию




8.6.3 Bars to right.
Задается параметр, определяющий величину сдвига изображаемого графика относительно оси цены. Для того, что бы задать величину сдвига, измеряемого в количестве баров (или свечах) пользователь должен кликнуть по рассматриваемому пункту меню и в появившемся окне задать (или изменить) значение параметра.

перейти к содержанию




8.6.4 Show/set to prev. close zero price
Используя этот пункт меню, пользователь имеет возможность выбора двух режимов отображения графиков: отображение на графике только периодов (бары или свечи), в течение которых были изменения цены; временные периоды, в течение которых цена не изменялась, отображаются в виде пропусков (окон) на графике. Для выбора первого режима, пользователю необходимо кликанием по самому пункту меню убрать галочку. Для второго режима - установить галочку в пункте меню.

перейти к содержанию




8.6.5 Hide Informer
Используя этот пункт меню, пользователь имеет возможность видеть ценовые параметры графика в отдельном окне в табличном в виде. Для этого, так же как и в предыдущем пункте, используется двоичный алгоритм при выборе необходимого режима - наличие отмечающей этот пункт меню галочки или её отсутствие. При наличии галочки у пункта меню и последующего нажатия правой кнопки мыши по фоновому полю графика появляется окно Information, в котором отображаются в табличном виде временные и ценовые характеристики графика, соответствующего временному периоду, соответствующему положению горизонтальной линии курсора, появляющегося при нажатии правой кнопки мыши. При отсутствии галочки - дополнительное окно не появляется.

перейти к содержанию




8.6.6 Hide Volume
Используя этот пункт меню, пользователь имеет возможность отображать в нижней части пространства для отображения ценового графика графического изображения параметра Объема сделок. Так же как и в предыдущих двух пунктах используется двоичный алгоритм - наличие отмечающей этот пункт меню галочки или её отсутствие. Выделение этого пункта меню галочкой вызывает появление в нижней части ценового поля экрана распределения гисторграммы параметра Объем сделки. На форексе под параметром Объем сделки понимается так называемый тиковый объем - число изменений цены за заданный интервал времени (например, за время формирования свечи, в случае свечного графика). Отсутствие галочки - отмена режима представления графика Объем сделок.

перейти к содержанию




8.6.7 Export to Metastock
При нажатии на этот пункт меню появляется окно, в котором отображаются данные графика в формате Метастока. (Подробнее)

перейти к содержанию




8.6.8 Print
Параметр, определяющий печать графика.
Настройка безопасности JavaVM для печати из Internet Explorer

перейти к содержанию




8.6.9 New Window
При нажатии на этот пункт меню появляется новое окно графика, в котором отображается график того же рыночного инструмента и с тем же период формирования.

перейти к содержанию




8.6.10 Informers
При наведении курсора на этот пункт появляется дополнительное меню, содержащее названия таблиц со страницы http://www.forexpf.ru/_quote_show_/java/. Кликая в появившемся подменю на название таблицы, вызываем появление на экране таблицы с соответствующим названием.

перейти к содержанию




8.6.11 Save
Выбирая этот пункт меню, пользователь может использовать режим записи на диск с заданным им именем полной конфигурации и настройки текущего окна. Для этого необходимо выбрать этот пункт меню. Появится окно Login, в котором пользователь вводит выбранные им параметры Login name и Password (например, Kolja и 1234) и далее, кликая по клавише Login, попадает в окно Configurations. В появившемся окне пользователь может ввести выбранное им имя для записи окна и сделать запись файла. Для того, что бы использовать далее в работе созданный и записанный файл конфигурации пользователю необходимо запомнить заданные им значения параметров Login name и Password. Под одними Login name и Password можно делать несколько записей с разными именами файлов.

перейти к содержанию




8.6.12 Load
Выбирая этот пункт меню, пользователь может считывать с диска необходимую конфигурацию и настройки окна, которую он создал ранее и записал в соответствии с п. 8.6.11. Для этого необходимо выбрать этот пункт меню. Появится окно Login, в котором пользователь вводит выбранные им ранее параметры Login name и Password и далее, кликая по клавише Login, попадает в окно Configurations. В появившемся окне пользователь может выбрать файл (отметить курсором) с необходимым именем и нажатием на клавишу Load загрузить в программу необходимые параметры.

перейти к содержанию




Copyright © 2003-2010 ProFinanceService.
  Услуги на рынке Forex / Форекс -

О компании · Услуги интернет трейдинга · Открытие торгового счета · Открытие демонстрационного счета · Контакты

 
Forex / Форекс платформа ProTrader -

Торговая платформа ProTrader 3.1

Графики и котировки Forex / Форекс -

Котировки · Котировки онлайн · Графики · Графики онлайн · Информеры - Курс валют ЦБ и Форекс

Быстрый переход

Котировки валют · Курс доллара к рублю · Курс евро к рублю · Курсы валют к рублю . Котировки акций · Нефть · Золото

Аналитика и прогнозы Forex / Форекс -    

Архив новостей валютного и фондового рынка · Архив экономических новостей и событий · Календарь экономических событий

Сообщество форекс - трейдеров -  

Форекс Форум · Дневники трейдеров


Новости и аналитика рынка валют Forex / Форекс, фондовых и сырьевых рынков на Forexpf.Ru - Copyright © 1995 - 2015 Pro Finance Service, Inc.
Условия использования материалов с сайта Forexpf.Ru / ProFinance.Ru · Реклама на сайте · Мы в сети: